WPupdatePHP is a PHP library to be bundled with WordPress plugins to enforce users to upgrade to PHP 5.4 or higher hosting.

Why we do this

The developers of the affiliated plugins no longer want to support these old versions of PHP.

PHP.net lists all unsupported versions.

What PHP versions are WordPress users running?

See for yourself. Then compare this to the list of unsupported PHP versions. This is why a proactive stance is needed.

No affiliation with WordPress or PHP

This project has no affiliation with WordPress or PHP. Developers using this library simply no longer want to work with old PHP versions, but do this on their own terms.