WPupdatePHP: Time to update your PHP version

This library and website aim to get everyone updated to at least a supported version of PHP.

WordPress has PHP 5.2.4 as the minimum required version. This is a version that has been unsupported since early 2011. The PHP 5.3.* versions have been unsupported since August 2014 as well. This means that these versions don't receive any updates, which leaves them potentially insecure.

PHP 5.4 is now the recommended version for WordPress, so we can actively start to ask hosts to update their PHP versions. This library helps you do that.

For non-developers

If you are not a developer, you should read our Time to update page.

Developers, bundle this library with your plugins!

Are you as sick as we are by having to make our code compatible with PHP 5.2? Good! You can now use our library to enforce your users to be at a minimum PHP version.

For all developers willing to contribute to this project, we have a library and more developer resources available. Please implement this library for new plugins only, we don't want to lock out users of existing plugins. It's not their fault after all.